Apple not used App ID is not available

I tried to build an ios app with expo-cli.

At first try it was successful, but when tried to upload to itunes connect, it said:

No suitable application records were found. Verify your bundle identifier <> is correct.

Then I tried to create a new application on itunes connect for this build. It failed with:

You have no eligible Bundle IDs for iOS apps.

So i thought maybe it was something cache problem (because when i was building the app, it didn’t ask to handle my credentials). I re-run the build, but this time with --clear-app-credentials. With that, the expo did recommend that it will handle by credentials, but when i typed in my apple id / password, it return wtih:

An App ID with Identifier <> is not available. Please enter a different string.

Someone has any idea what can cause such problem?

Hey @fitsolutionskft,

If I’m understanding this correctly, it looks like you may need to create a more unique bundleIdentifier than that follows Apple’s namespace guidelines. Perhaps something like

On second thought, I just read another post mentioning this same issue so I’m thinking it may be on our end rather. I’ll keep you updated.



As i said in the end of my post: I replaced the actual bundle id with , the is just a replacement of the actual bundle id because of security stuff.

The actual bundle id has the correct format [country code].[domain].[app name].

I hope that helps.

I changed the '' to <> to avoid these misunderstanding.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.