App quits unexpectedly on iOS after detach (but works fine on Android)

Hello everyone. Let me describe my situation. I had a fully working app on Expo. But at some point I needed to detach it. I followed thoroughly all this instructions As a result I can run my detached app on Android, but when I try to run it on iOS that’s what happens:

  1. app builds successfully
  2. simulator opens
  3. app starts loading
  4. app quits unexpectedly and simulator shows a home screen

In xCode I got the following error

I’ve tried to google this error, but seems like this error code doesn’t point at some specific error, so further debugging required (debugging of Objective-C code, and I have experience with js only). Also I’ve tried different simulators. Hasn’t helped.

Any advice, guys? I would appreciate any help

Hey all,

I’m running into the same issue. Anyone have any ideas?

Missed this topic the first time around, but the most likely explanation is that the detached project’s Info.plist is missing some *UsageDescription key for some API you’re trying to use after detaching. More recently we try to provide these for you. I suggest thinking about whether you’re making use of any APIs that require this kind of Usage Description, and seeing if the app’s crashing at the time you try to use them.

create-react-native-app is good work for me… :blush: