App on Play store not getting updated

In October I have upgraded my app to use Expo 35, and as a result I uploaded a new version of the apk to the play store. Everything worked perfectly, and my users got the new version of the app.
Now I didn’t update my app since this week, and now I realize I’m not able to publish new content anymore to the app using expo publish.

When scanning the QR code on my Expo page, I get the latest version opening in expo, but when launching the actual app downloaded from the Play store, I still see the old version.

I feel like the app is not listening to the OTA updates anymore. Any reason why?


EDIT: I actually tried to install the app through the Play store on another device, and the sync is working properly there. What does it mean? How can I be sure all my users have access to my updates?

  Expo CLI 3.11.7 environment info:
      OS: macOS 10.15.2
      Shell: 5.7.1 - /bin/zsh
      Node: 10.16.3 - /usr/local/bin/node
      npm: 6.9.0 - /usr/local/bin/npm
      Xcode: /undefined - /usr/bin/xcodebuild
      expo: ^35.0.0 => 35.0.0
      react: 16.8.3 => 16.8.3
      react-native: => 0.59.8
      react-navigation: ^2.9.3 => 2.18.3
      expo-cli: 3.11.7

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.