App launch is delayed in production


When my app is opened in the background and I try to open it in production, it will take 5-10 seconds to open. But when I launch it inside the Expo client, it behaves normally.

There are two very strange things here:

  • Within the 5-10 seconds of opening, if I tap on the screen as if the app was already opened, the app responds. It’s like it is already opened but simply transparent.
  • The issue only happens on a Huawei with Android 7. I tried on several other devices with Android 6, 7 or 8 and everything is fine.

I recorded a quick video to illustrate my issue for better understanding.
On the left, we have the app inside the Expo client and on the right, the app from the PlayStore. You can see that on the right, the keyboard appears instantly because a text input is currently focused in the app, but the app only appears after a few seconds.


I ran adb logcat but no error is raised…

I apologize in advance if this is not the best place to post my issue. If it is not, I would appreciate if you could point me in the right direction for this.


Hey @emixis,

This definitely seems like a bug. The best course of action would be for you to create an issue here: with as much relevant details as you can provide such as device models, sdk version, etc. If you’re able to share your APK as well, that would be excellent. If you’re able to, you can email



Will do so, thanks for the quick reaction.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.