App is Stuck on SplashScreen Android

Hello there,

Recently I have update Expo SDK from 45 to 47 also migrating from expo classic build to EAS build.

Project Specification
Expo SDK 47
eas-cli/3.1.1 darwin-x64 node-v16.18.1

My Dependency:

 "@react-native-async-storage/async-storage": "~1.17.3",
    "@react-native-community/netinfo": "9.3.5",
    "@react-navigation/bottom-tabs": "^6.5.0",
    "@react-navigation/native": "^6.1.0",
    "@react-navigation/stack": "^6.3.8",
    "color-hash": "2.0.1",
    "expo": "^47.0.0",
    "expo-app-loading": "~2.1.1",
    "expo-application": "~5.0.1",
    "expo-av": "~13.0.2",
    "expo-camera": "~13.1.0",
    "expo-constants": "~14.0.2",
    "expo-dev-client": "~2.0.1",
    "expo-document-picker": "~11.0.1",
    "expo-font": "~11.0.1",
    "expo-image-manipulator": "~11.0.0",
    "expo-image-picker": "~14.0.2",
    "expo-intent-launcher": "~10.3.1",
    "expo-keep-awake": "~11.0.1",
    "expo-linking": "~3.2.3",
    "expo-location": "~15.0.1",
    "expo-notifications": "~0.17.0",
    "expo-sensors": "~12.0.1",
    "expo-splash-screen": "~0.17.5",
    "expo-updates": "~0.15.6",
    "lodash": "^4.17.20",
    "mobx": "^5.8.0",
    "mobx-react": "6.3.1",
    "moment": "2.29.4",
    "moment-timezone": "0.5.39",
    "react": "18.1.0",
    "react-native": "0.70.5",
    "react-native-autolink": "4.0.0",
    "react-native-draggable-flatlist": "4.0.0",
    "react-native-dropdown-picker": "5.4.3",
    "react-native-easy-toast": "2.3.0",
    "react-native-gesture-handler": "~2.8.0",
    "react-native-image-progress": "1.2.0",
    "react-native-keyboard-aware-scroll-view": "0.9.5",
    "react-native-modal": "^13.0.1",
    "react-native-progress": "5.0.0",
    "react-native-reanimated": "~2.12.0",
    "react-native-render-html": "5.1",
    "react-native-safe-area-context": "4.4.1",
    "react-native-screens": "~3.18.0",
    "react-native-svg": "13.4.0",
    "react-native-webview": "11.23.1",
    "victory-native": "^36.6.8"

I tried to build apk using eas build for internal testing which works fine but when I tried to create production apk it’s stuck on splash screen

I tried:
I tested notification on Expo go as well as development apk build, notifications are working as expected but It gives me this error when I generated apk for production
I tried to debug apk on Android studio in Logcat I found this error

Please Help me because of this I’m not able to upload my app on play store.
Any Suggestion

Thank you in advance

I’m facing a similar issue but on IOS. Check out my reply here

1 Like

Hey thank you so much It worked for me. I was using Constants.manifest2 || Constants.manifest to get the version of my app I updated it with Constants.expoConfig now it works fine

1 Like