App is stuck on Splash screen

Hey all,

I faced a similar issue. The app was just stuck on loading screen for my latest build on TestFlight. I spent almost 2 days trying to fix the issue and here’s what I did to finally fix it (sort of). Would appreciate if you guys have any feedback

  1. Ran “expo start --no-dev --minify” the app worked locally as well as expo go.
  2. Next I ran depcheck to remove any unused dependancies. Following which i deleted the package.json and yarn.lock files and reinstalled the packages. (No luck. App was still stuck on loading screen)
  3. Finally I checked to see if i forgot to call SplashScreen.hideAsync() after SplashScreen.preventAutoHideAsync(). However I did call the SplashScreen.hideAsync() function. Therefore, I checked the code that ran before the hideAsync function. I noticed that I was checking for OTA updates before the hideAsync call. I did have a mistake in my code where i was not using a try, catch for fetchUpdateAsync() as mentioned here

However this time i decided to push this update using the EAS update feature and boom!! the app went past the loading screen once it downloaded the new update.

I assumed all was good and so i rebuilt the app using the EAS build command to test if it would open on TestFlight. However, App was stuck again on loading screen. I tried sending a new OTA and it went passed the loading screen again. Has anyone faced this before? I feel like something is wrong with my EAS update setup where my app gets stuck on loading screen the first time it loads but if i use EAS Update the app launches.

1 Like