App is failing to deliver via transporter due to SDK issue

Please provide the following:

  1. SDK Version:41
  2. Platforms(Android/iOS/web/all): iOS

I have been using below versions to build the application and those are same as per the requirement specified by Apple, but still it is giving me the below error when I’m trying to upload the application to testflight.
These are the versions I’m using:

  • Xcode -: 13.4
  • iOS Sdk -: 15.5
  • Expo-Cli -: 5.4.7
  • Expo -: 41

Here is the error I’m getting:

Note: I have also tried to verify the app before delivering but verification is also giving the same error.

I see you are using classic builds, so even though xcode version on turtle builder is new enough to include iOS 15 support, the version of xcode that was used to create that prebuild is the issue.

If you want to state on classic builds your only option is to update to newer SDK(preferably latest)

If you are willing to migrate to EAS Build you should be able to build it with ios 15 but, I would recommend to upgrade to latest SDK either way. I don’t know for sure if it will work, but one thing you might want to try is to specify env EXPO_USE_SOURCE=1 in eas.json to compile it from sources (not 100% sure if it’s necessary).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.