App ejected to ExpoKit won't run

I made a new app using $ expo init(expo-cli version 2.4.0). I changed App.js to have the contents of the camera basic example, I set the ios and android bundleIdentifiers in package.json, and i ejected using $ expo eject.

I said yes to ejecting with expo kit. I ran $expo start to start the js bundler. I installed cocoa pods in the /ios directory. I launched the project in Xcode by double clicking on the .xworkspace directory. I updated the Build Phases > Prepare Expo to use this script, and I unchecked OS_ACTIVITY_MODE in the build scheme.

Now when I run the app, I get this error:

mytestexpoproject[41164:7233942] *** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'You are running a detached app from Xcode, but it hasn't been configured for local development yet. You must run a packager for this Expo project before running it from XCode.'

Does anyone have any idea what might be going on?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.