App closes after clicking "Debug JS Remotely" when running the app with `expo start --android --offline`

Please provide the following:

  1. SDK Version: 39
  2. Platforms(Android/iOS/web/all): Android

I want to run my project on an actual device without having the need to connect my phone on a wifi network where my computer is also connected on. So I tried expo start --android --offline (also tried adding --dev), It runs but the app closes after opening the Menu and choosing “Debug JS Remotely”. I want to debug over the usb cable and not through the Wifi network because our company’s machines are only wired and we wifi is not available/allowed.

This is a known problem:

I see the two pull requests mentioned in the issue were merged yesterday so I expect the fix will be released soon.

It looks like this has now been fixed:

Expo app is crashing at launch on samsung android 10, works fine on Huawei android 9.
Works fine on ios

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.