App built after 4 Nov 2022 shortage crashing at launch

Since before the shortage problem, I was building and running the APK without problems.

Now if I build and test the APK, it crashes. I even tried to “git checkout” older versions I made, and they crash as well.

I even have a build did before the shortage, and it works.

What’s going on?

Just using the basic eas.json and running “preview” profile

  "build": {
    "preview": {
      "android": {
        "buildType": "apk"
    "preview2": {
      "android": {
        "gradleCommand": ":app:assembleRelease"
    "preview3": {
      "developmentClient": true
    "production": {}

My dependencies

    "@react-native-async-storage/async-storage": "~1.17.3",
    "@react-navigation/native": "^6.0.13",
    "@react-navigation/native-stack": "^6.9.1",
    "@reduxjs/toolkit": "^1.8.6",
    "expo": "~46.0.16",
    "expo-image-picker": "~13.3.1",
    "expo-local-authentication": "~12.3.0",
    "expo-status-bar": "~1.4.0",
    "expo-system-ui": "~1.3.0",
    "html-to-formatted-text": "^2.7.0",
    "react": "18.0.0",
    "react-native": "0.69.6",
    "react-native-dialog": "^9.3.0",
    "react-native-heroicons": "^3.2.0",
    "react-native-pell-rich-editor": "^1.8.8",
    "react-native-popup-menu": "^0.16.1",
    "react-native-safe-area-context": "4.3.1",
    "react-native-screens": "~3.15.0",
    "react-native-svg": "12.3.0",
    "react-native-webview": "11.23.0",
    "react-redux": "^8.0.4",
    "react-uuid": "^1.0.3",
    "redux": "^4.2.0",
    "redux-persist": "^6.0.0"

Yes, exact same issue here. Our Android EAS builds started failing during the outage described here: Expo Status - Upstream issue with React-Native release causing all Android builds to fail - once the outage was resolved, builds started succeeding again, but attempting to run the built apps and they crashed immediately on launch.

Checked out a previous version that built and ran fine 2 days ago – it still runs fine by downloading that old APK. But attempting to rebuild the APK with exactly the same settings, and it crashes on launch.

Have tried swapping between APK/AAB, but still crashed immediately, however swapping from Hermes to JSC solved the crash.

Dependencies (among others):

    "expo": "^46.0.0",
    "expo-splash-screen": "~0.16.2",
    "expo-updates": "^0.14.6",
    "react": "18.0.0",
    "react-native": "0.69.6",

Yeah I was using Hermes as well. So the workaround they used to fix the shortage created problems on Hermes engine…

I hope they read this post, and try to investigate the issue. I will swap momentarily to JSC engine.

We have resolved this issue by temporarily disabling the Maven cache on EAS Build. Please run your build again. We will investigate the root cause on Monday.

1 Like

Thanks Brent, can confirm Hermes Android builds are working again.