Android "Unfortunately, Expo has stopped" (Mac)

Hey everyone,

I’m having a problem recently with Expo and android devices. Since the new expo version update on MacOS, every time I want to test my app with the Android simulator / publish it and scan the QR code with an Android device, I have the same result : “Unfortunately, Expo has stopped”.

I don’t understand, I’ve been using Expo for 2 weeks, everything was fine. It worked perfectly with android devices when I published my versions.

Any idea ? :slight_smile:


I’m facing the same issue too! My app was working fine with iOS but Android couldn’t seem to start the Expo app at all!

Is there any updates on this issue?


I’m still having this issue. My app works fine with Expo on iOS emulator but not on Android anymore.

I published it, same problem. Works fine with iOS but crashes on Android.

Check :

Here are my dependencies :

“dependencies”: {
"@ptomasroos/react-native-multi-slider": “0.0.11”,
“expo”: “^22.0.0”,
“moment”: “^2.19.1”,
“parse”: “^1.10.1”,
“react”: “16.0.0-beta.5”,
“react-native”: “”,
“react-native-check-box”: “^2.0.2”,
“react-native-elements”: “^0.15.0”,
“react-native-keyboard-aware-scroll-view”: “^0.3.0”,
“react-native-modal-datetime-picker”: “^4.13.0”,
“react-native-modal-dropdown”: “^0.5.0”,
“react-native-modalbox”: “^1.4.2”,
“react-native-svg”: “^5.3.2”,
“react-navigation”: “^1.0.0-beta.11”,
“react-redux”: “^5.0.5”,
“redux”: “^3.7.2”

Any idea ? Thanks in advance for your precious help !


Hey @alexjamin and @jeemok , thanks for reporting this issue. Would it be possible for you to give us the simplest possible version of the app that doesnt work on android emulator that you are comfortable showing publicly? Once we have that, I can go ahead and make a github issue and we can track this. Sorry for the inconvenience!

Hi Quinlanj,

Thanks for your quick reply!

Turned out it was one of the codes that crashes the app…

the same code was able to run on iOS device but not on Android… which is weird

It took me hours to find out the problem ( it’d be better if I could get an error message ); the code was:

new Date().toLocaleString()

after I changed it to use moment.js library it work fine on both iOS and Android devices.

hey @jeemok – that would do it. We use javascriptcore and locale calls to Date are not supported.

@alexjamin can u confirm that this is ur issue too?

It’s actually different. It seems that the Android emulator is more restrictive than the iOS emulator. For instance, I had made a mistake in my TextInput component props, it worked perfectly on iOS emulator but not on Android emulator …