Android stuck on splash screen


I have got an ejected project, using expo v35.0.0. It was working fine.

We are trying to integrate react native firebase, which need to upgrade gradle version and google services version. I also migrated to AndroidX via Android studio.

After some play around, I managed to get the app working in dev mode with the following versions:


    classpath ''
    classpath ''


However, when I try to run release build on a device, it stuck on the splash screen.

Searched on the internet, and figured out a way to simulate the issue on emulator, by running expo start --no-dev --minify.

Then I can see the console says [Error: No value for revisionId]. Could not find any clue on what the error is.

I also tried to upgrade expo to 36.0.0. Got the same error.

Any help is appreciated.

1 Like

I am having a similar issue with my Android build of React Native code. The error message is straight forward but I cannot find a way to resolve it. I’ve done my best to google it but most of the questions out there end up like this one or closed with no resolution. I hope someone stumbles across this and can give some guidance.