Android standalone app crashes


Today I did a little update on my app and generated the Android standalone build via expo-cli build:android. When I tried that build on my phone, the app crashed on start.

After that, I reverted the changes, did a new build and the new apk was still crashing. The app works fine in local and in Expo’s simulator.

I noticed that this new apk was way smaller (19MB vs 27MB) than the last apk that worked successfully, while both were generated with the same code and expo version.

This is the build that crashes:

Any idea why the build size is so different? Any tip on how to debug this crashing apk?


1 Like

Hey, @mllocs! Sorry for the inconvenience! The issue should be resolved now, try rebuilding the application! :slightly_smiling_face:

Hi i have same issue build via expo-cli and the app still crash

can you help?

this is the build :

Huh, it does work on my Android test device (Nexus 5, Android 6.0.1)… On what device does the app crash?

Lenovo, Android 4.4.4, the apps seems stuck endless loop in loading screen

I got the app worked before im updating to new expo-cli

Hello @sjchmiela, the issue is fixed after rebuilding the app. Thank-you!

Hi, any updates? my issue still continues

need help

I have just successfully reproduced the issue on Android 4.4 emulator (real devices with newer Androids worked all right). I’ll try to debug and fix it. :slightly_smiling_face:

@juonliners your issue is more related to the topic below, I’ll track the problem there!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.