Android Standalone APK: newLatLngBounds error now

This is a new issue, seemingly something to do with google maps API - came out of nowhere for us. It seems impossible but our production app suddenly started throwing an occasional error on our startup screen. Our startup screen is mostly a google Map, which is MapView for expo.

Uncaught Error: Error using newLatLngBounds(LatLngBounds, int): Map size can't be 0. Most likely, layout has not yet occured for the map view. Either wait until layout has occurre or use newLatLngBounds(LatLngBounds, int, int, int) which allows you to specify the map's dimensions.

This only happens on our Android standalone app, through Expo it works fine.

We followed the docs for Android: - we’ve went through these steps. To the best of our knowledge we’ve done the process twice with different API keys, and we get the same result.

We’ve tried fixes suggested here: Error using newLatLngBounds(LatLngBounds, int, int, int): Map size can't be 0. · Issue #1501 · react-native-maps/react-native-maps · GitHub, namely setting height and width based on dimensions, setting flex:1, and setting initialLocation. Nothing seems to work.

The github link above does have someone running into this as of today. Any ideas how to even debug this?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.