Android notifications suddenly not working anymore

  1. SDK Version: 48
  2. Platforms(Android/iOS/web/all): Android

Since upgrading from Expo SDK 45 to 48 (and therefore migrating from the firebase js sdk to the official react-native package), notifications on Android are not working anymore (tested with the online notification tool as well).

Nothing was changed in the corresponding google & firebase accounts or the google-services.json file.

Anyone else having this issue?

First of all, sending a notification locally still works

I followed the guide here for debugging the notification handling.

Sending a notification from the terminal as shown in the curl example worked and I got the response {"data":{"status":"ok","id":<id>}}

Then, trying to get the receipt using the other curl command, I only received a plain Not Found None of the errors mentioned.

simply uninstalling the messaging package from react-native-firebase solved the issue (even though I was not using it) There seems to be some internal clash between it and the expo-notification module


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.