Android build started failing

Started today, not sure how to proceed.
All help is appreciated.

ERROR from build logs:

> Task :app:preBuild UP-TO-DATE
> Task :app:extractProguardFiles
> Task :app:preReleaseBuild
> Task :app:compileReleaseRenderscript NO-SOURCE
> Task :app:generateReleaseResValues
> Task :app:generateReleaseResources
> Task :app:processReleaseGoogleServices
Parsing json file: /app/turtle/workingdir/android/sdk39/android-shell-app/app/google-services.json
> Task :app:mergeReleaseResources FAILED
[stderr] FAILURE: Build failed with an exception.
[stderr] * What went wrong:
[stderr] Execution failed for task ':app:mergeReleaseResources'.
[stderr] > 
[stderr] Could not resolve all files for configuration ':app:releaseRuntimeClasspath'.
[stderr]    > Could not find facebook-login-5.12.1.aar (
[stderr]      Searched in the following locations:
[stderr]    > Could not find facebook-common-5.12.1.aar (
[stderr]      Searched in the following locations:
[stderr] * Try:
[stderr] Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.
[stderr] * Get more help at
[stderr] BUILD FAILED in 35s
Deprecated Gradle features were used in this build, making it incompatible with Gradle 7.0.
Use '--warning-mode all' to show the individual deprecation warnings.
4 actionable tasks: 4 executed
Error: ./gradlew exited with non-zero code: 1
    at ChildProcess.completionListener (/app/turtle/node_modules/@expo/xdl/node_modules/@expo/spawn-async/build/spawnAsync.js:52:23)
    at Object.onceWrapper (events.js:418:26)
    at ChildProcess.emit (events.js:311:20)
    at ChildProcess.EventEmitter.emit (domain.js:482:12)
    at maybeClose (internal/child_process.js:1021:16)
    at Process.ChildProcess._handle.onexit (internal/child_process.js:286:5)
    at spawnAsync (/app/turtle/node_modules/@expo/xdl/node_modules/@expo/spawn-async/build/spawnAsync.js:17:21)
    at spawnAsyncThrowError (/app/turtle/node_modules/@expo/xdl/build/detach/ExponentTools.js:201:45)
    at buildShellAppAsync (/app/turtle/node_modules/@expo/xdl/build/detach/AndroidShellApp.js:975:11)
    at async Object.createAndroidShellAppAsync (/app/turtle/node_modules/@expo/xdl/build/detach/AndroidShellApp.js:396:5)
    at async runShellAppBuilder (/app/turtle/build/builders/android.js:95:9)
    at async Object.buildAndroid [as android] (/app/turtle/build/builders/android.js:43:28)
    at async build (/app/turtle/build/jobManager.js:181:33)
    at async processJob (/app/turtle/build/jobManager.js:118:32)
    at async Object.doJob (/app/turtle/build/jobManager.js:49:5)
    at async main (/app/turtle/build/server.js:66:13)
expo diagnostics

  Expo CLI 3.28.5 environment info:
      OS: macOS 10.15.7
      Shell: 5.7.1 - /bin/zsh
      Node: 10.21.0 - /usr/local/opt/node@10/bin/node
      npm: 6.14.4 - /usr/local/opt/node@10/bin/npm
      iOS SDK:
        Platforms: iOS 14.1, DriverKit 19.0, macOS 10.15, tvOS 14.0, watchOS 7.0
      Android Studio: 4.0 AI-193.6911.18.40.6626763
      Xcode: 12.1/12A7403 - /usr/bin/xcodebuild
      expo: ^39.0.0 => 39.0.3
      react: 16.13.1 => 16.13.1
      react-dom: 16.13.1 => 16.13.1
      react-native: => 0.63.2
      react-native-web: ~0.13.7 => 0.13.14
      expo-cli: 3.28.5
    Expo Workflow: managed

  "expo": {
    "name": "Ana Bekoach",
    "description": "The Ana Bekoach prayer, formed by Rav Nehunya ben HaKanah between the first and second century, is considered one of the most powerful prayers for connecting us to the power of creation. The kabbalists explain that each time we recite the Ana Bekoach, we return to the time of creation, and each time we meditate on a particular sequence, we return to the original uncorrupted energy that built the world. By performing the Ana Beko’ach meditation, we enrich our lives with unadulterated spiritual Light and cosmic energy.",
    "slug": "abk",
    "privacy": "public",
    "version": "1.0.5",
    "platforms": ["ios", "android"],
    "orientation": "portrait",
    "icon": "./assets/icons/icon.png",
    "splash": {
      "resizeMode": "cover",
      "image": "./assets/images/paper-background.png",
      "backgroundColor": "#ffffff"
    "updates": {
      "fallbackToCacheTimeout": 0
    "assetBundlePatterns": ["**/*"],
    "ios": {
      "bundleIdentifier": "net.velsa.ana-bkoach",
      "buildNumber": "1.0.5",
      "supportsTablet": true
    "android": {
      "package": "net.velsa.ana_bkoach",
      "versionCode": 5,
      "permissions": [],
      "splash": {
        "image": "./assets/images/paper-background.png",
        "resizeMode": "cover",
        "backgroundColor": "#ffffff"
    "web": {
      "favicon": "./assets/icons/favicon.png"
    "sdkVersion": "39.0.0"

hey @velsa, I think this may have been an intermittent issue. That aar is available when you visit the link (at least it was when I just tried it), so could you try running another build?

Yes, just ran it and it worked fine )
Thanks a lot for the quick response and fix!

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.