Android build stalling without error

For some reason my EAS builds are timing out on run gradlew

They seem to be timing out at this stage every time
Task :expo-modules-core:bundleReleaseLocalLintAar

I am using a managed workflow, a list of my dependencies are below

 "dependencies": {
    "@expo/webpack-config": "^0.17.2",
    "@react-native-async-storage/async-storage": "~1.17.3",
    "@react-native-community/datetimepicker": "6.5.2",
    "@react-native-community/netinfo": "9.3.5",
    "@react-navigation/drawer": "^6.3.1",
    "@react-navigation/material-top-tabs": "^6.2.1",
    "@react-navigation/native": "^6.0.8",
    "@shopify/flash-list": "1.3.1",
    "@taoqf/react-native-mqtt": "^3.0.4",
    "babel-plugin-module-resolver": "^5.0.0",
    "clsx": "^1.2.1",
    "expo": "^47.0.0",
    "expo-battery": "~7.0.0",
    "expo-brightness": "~11.0.1",
    "expo-font": "~11.0.1",
    "expo-keep-awake": "~11.0.1",
    "expo-linking": "~3.3.0",
    "expo-screen-orientation": "~5.0.1",
    "expo-status-bar": "~1.4.2",
    "expo-updates": "~0.15.6",
    "mqtt": "^4.3.7",
    "nativewind": "3.0.0-next.34",
    "react": "18.1.0",
    "react-dom": "18.1.0",
    "react-native": "0.70.5",
    "react-native-circular-progress-indicator": "^4.4.2",
    "react-native-dropdown-picker": "^5.4.2",
    "react-native-gesture-handler": "~2.8.0",
    "react-native-maps": "1.3.2",
    "react-native-modal": "^13.0.1",
    "react-native-pager-view": "6.0.1",
    "react-native-reanimated": "~2.12.0",
    "react-native-safe-area-context": "4.4.1",
    "react-native-super-grid": "^4.6.1",
    "react-native-svg": "13.4.0",
    "react-native-tab-view": "^3.1.1",
    "react-native-toast-notifications": "^3.2.3",
    "zustand": "^4.3.2"

So far I have tried running `expo doctor`, going through dependencies and removing unused ones, and tried going through the error logs (no errors produced)

This has been an ongoing issue for 2 weeks now

you will need to go through the lengthy build log to where the error occurs to narrow down what the error is. Maybe post your build log, just the error part

Hi @jamescortex

Only Expo team members can view your logs, so unfortunately I can’t :slight_smile:

Could you post the parts that lead you to the above conclusion?

Hi Wodin,

I have tried updating to the latest expo SDK of 48, however, a similar issue persists
it keeps getting stuck on

> Task :app:collectReleaseDependencies
> Task :app:sdkReleaseDependencyData
> Task :app:validateSigningRelease
> Task :app:writeReleaseAppMetadata
> Task :app:writeReleaseSigningConfigVersions``


What’s the Build time and Start time?

Also can you turn on the “Show timestamps” option (in the “…” menu in the Run gradlew section) to show how long after the build starts it gets to the above tasks?