Android: Build in progress... after one day

exp build:status
[exp] Making sure project is set up correctly…
[exp] Your project looks good!
[exp] Checking if current build exists…

[exp] ============
[exp] Build Status
[exp] ============

[exp] Android: Build in progress…

Hi-

That sucks, sorry :frowning:

Can you try two things for me?

  1. Make sure you are upgraded to the latest version of exp.
    You can do this by running npm upgrade -g exp (or if you’re using yarn, then yarn global upgrade exp)

Once you do this, then when you run exp --version at the command line, you should see 42.2.0.

  1. Try rerunning exp build:android.

Hopefully it will just work this time, but if it doesn’t, it should give you a request id or a build id that looks something like this:

[exp] Build ID: 2a8dc30a-9b55-43d5-9c0f-3d4a8e57308e

or

    [exp] Unable to validate credentials. Request ID 5f6ffc70-62a5-11e7-b6a8-1d0bb0d33c86, message: ...

We can use those to dig into what’s wrong if its still not working.

So sorry again you’re having trouble. :frowning: We’re working right now on making this more reliable and better.

Nixon-Macbook-Pro:Pesquiza nixon$ npm upgrade -g exp
/usr/local/bin/exp -> /usr/local/lib/node_modules/exp/bin/exp.js

  • lodash-node@3.10.2 node_modules/exp/node_modules/lodash-node
    /usr/local/lib
    └── exp@43.0.0
    npm WARN react-redux@5.0.5 requires a peer of react@^0.14.0 || ^15.0.0-0 || ^16.0.0-0 but none was installed.
    Nixon-Macbook-Pro:Pesquiza nixon$ exp --version
    43.0.0
    Nixon-Macbook-Pro:Pesquiza nixon$ exp build:android
    [exp] Making sure project is set up correctly…
    [exp] Your project looks good!
    [exp] Checking if current build exists…
    [exp] ============
    [exp] Build Status
    [exp] ============
    [exp] Android: Build in progress…
    [exp] Cannot start new build, as there is a build in progress.

Same error … I think it was because I ran the build command before publishing my app … and i did not informed slug on app.json …

2 days… some solution? =/

1 Like

Hi! I’m so sorry about the delay on this. I’ve cleared the hung job, can you please try again?

Also, if you have the updated exp it should provide you with a build ID when you start the job that will make this easier to diagnose if something goes wrong again.

Thanks a lot… It is working now =)

mine is also taking a super long time <1h.
Build ID: ea4ad5eb-4572-4c3c-b686-f2bf2fce4d5e

@cono52 it seems like your build finished successfully. Check with exp build:status.

Hi,

I also have same problem now. I need your help to solve. I I’m not sure this is the build ID or not, but please check following.
a438a224-b1cd-466c-b5e7-a1a56bce46c6

Thanks.

sorry it finished just before… nvm.

hmm, now building android standalone app is taking long time again. this is the build ID: 047ac312-717e-4b66-a631-77f77e86e5c7
Could you check it?

Thanks.

Hi there –

We had some issues with the Android builders this evening.

The issue has been fixed and the queue is processing.

Sorry for the inconvenience.

-Adam (@skevy)

Dear All, the same problem here. It’s been 3 to 4 hours. Please your help.
Build ID: 25dec0c1-aa6b-4b5f-a34b-934540cb99e6

Hi, my builds were completing pretty quick like 10-15 mins before. Same build size almost no changes except some package.json file changes. Can u check on this build id: 429d02a0-e142-4f69-961b-98c27c3a0b9c. Its been more than an hour if i am correct.

@karanmartian we’re seeing:

Apple provided the following error info:
	In House distribution provisioning profiles for this account will be available two weeks after program activation.

come back from Apple.

@cris sorry for the delay. I’m not able to find your build’s logs within the last 7 days (looks like you posted 4 days ago). Have you tried again recently?

@dikaiosune Hi Adam, after two days I did not keep trying, and finally I created another account. Thank you :smiley:

well i built for android if i remember

can u please check this again. Its still showing Android build in progress and I dont understand the Apple note that you posted.