Android build fail with SDK36

Today i try to make build with the new sdk and fails on Android, iOS works as expected.

Here the exception, any advices, thanks !!!

32 actionable tasks: 32 executed
Error: ENOENT: no such file or directory, lstat '/app/turtle/workingdir/android/sdk36/android-shell-app/app/build/outputs/bundle/release/app.aab'
1 Like

can confirm got exactly the same mistake, please fix and keep us posted on the progress

I get the same error, both using turtle-cli and Expo’s services with SDK 36

This only happens for app-bundle, apk is not affected.

The error is here expo-cli/AndroidShellApp.js at @expo/xdl@56.5.0 · expo/expo-cli · GitHub

And the proper fix could be

if (ExponentTools.parseSdkMajorVersion(sdkVersion) >= 36) {
  gradleBuildCommand = `bundle${debugOrRelease}`;
  outputPath = path.join(outputDirPath, debugOrReleaseL, `app-${debugOrReleaseL}.aab`);
} else if (ExponentTools.parseSdkMajorVersion(sdkVersion) >= 33) {

This at least worked for me when I edited node_modules/turtle-cli/node_modules/@expo/xdl/build/detach/AndroidShellApp.js to be

  if (buildType === 'app-bundle') {
    if (ExponentTools().parseSdkMajorVersion(sdkVersion) >= 36) {
      gradleBuildCommand = `bundle${debugOrRelease}`;
      outputPath = _path().default.join(outputDirPath, debugOrReleaseL, `app-${debugOrReleaseL}.aab`);
    } else if (ExponentTools().parseSdkMajorVersion(sdkVersion) >= 33) {
1 Like

Guy, here i create a github issue with this post @esamelson any advice from expo voice, thanks !!!

Thanks for the report everyone and especially @hilmarh for the investigation into it. We’ll work on getting a fix out as soon as possible!


Thanks @adamjnav we stay tuned

Having this issue too.

Guys working for me right now, thanks !!!

1 Like

Hey all, as @outatime mentioned, it should be working now. We rolled out a fix late last night. Thank you for your patience and understanding!

Thank you @adamjnav for all the team effort they are doing expo awesome :raised_hands:

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.