After Upgrade to Expo 46, Expo Doc gave warning on @expo/config-plugins@^5.0.0

Hey guys!

Need your help! I have just upgrade from 45 to 46, and when I build, Expo Doc pop up this error:
image

When I run why, below is the super long, very intimidating message:

npm why @expo/config-plugins
npm WARN config global `--global`, `--local` are deprecated. Use `--location=global` instead.
@expo/config-plugins@5.0.1
node_modules/@expo/config-plugins
  @expo/config-plugins@"~5.0.0" from expo-av@12.0.4
  node_modules/expo-av
    expo-av@"~12.0.4" from the root project
  @expo/config-plugins@"~5.0.0" from expo-build-properties@0.3.0
  node_modules/expo-build-properties
    expo-build-properties@"~0.3.0" from the root project
  @expo/config-plugins@"~5.0.0" from expo-dev-menu@1.2.0
  node_modules/expo-dev-menu
    expo-dev-menu@"1.2.0" from expo-dev-launcher@1.2.0
    node_modules/expo-dev-launcher
      expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
      node_modules/expo-dev-client
        expo-dev-client@"~1.2.0" from the root project
    expo-dev-menu@"1.2.0" from expo-dev-client@1.2.0
    node_modules/expo-dev-client
      expo-dev-client@"~1.2.0" from the root project
  @expo/config-plugins@"~5.0.0" from expo-dev-launcher@1.2.0
  node_modules/expo-dev-launcher
    expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
    node_modules/expo-dev-client
      expo-dev-client@"~1.2.0" from the root project
  @expo/config-plugins@"~5.0.0" from expo-dev-client@1.2.0
  node_modules/expo-dev-client
    expo-dev-client@"~1.2.0" from the root project
  @expo/config-plugins@"~5.0.0" from expo-file-system@14.1.0
  node_modules/expo-file-system
    expo-file-system@"~14.1.0" from expo-asset@8.6.1
    node_modules/expo-asset
      expo-asset@"~8.6.1" from expo@46.0.7
      node_modules/expo
        expo@"^46.0.0" from the root project
        peer expo@"*" from expo-application@4.2.2
        node_modules/expo-application
          expo-application@"~4.2.2" from expo@46.0.7
        peer expo@"*" from expo-constants@13.2.3
        node_modules/expo-constants
          expo-constants@"~13.2.2" from expo-asset@8.6.1
          expo-constants@"~13.2.3" from expo@46.0.7
          expo-constants@"~13.2.0" from expo-linking@3.2.2
          node_modules/expo-linking
            expo-linking@"~3.2.2" from the root project
        peer expo@"*" from expo-av@12.0.4
        node_modules/expo-av
          expo-av@"~12.0.4" from the root project
        peer expo@"*" from expo-build-properties@0.3.0
        node_modules/expo-build-properties
          expo-build-properties@"~0.3.0" from the root project
        peer expo@"*" from expo-dev-menu@1.2.0
        node_modules/expo-dev-menu
          expo-dev-menu@"1.2.0" from expo-dev-launcher@1.2.0
          node_modules/expo-dev-launcher
            expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
            node_modules/expo-dev-client
              expo-dev-client@"~1.2.0" from the root project
          expo-dev-menu@"1.2.0" from expo-dev-client@1.2.0
          node_modules/expo-dev-client
            expo-dev-client@"~1.2.0" from the root project
        peer expo@"*" from expo-dev-launcher@1.2.0
        node_modules/expo-dev-launcher
          expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
          node_modules/expo-dev-client
            expo-dev-client@"~1.2.0" from the root project
        peer expo@"*" from expo-dev-client@1.2.0
        node_modules/expo-dev-client
          expo-dev-client@"~1.2.0" from the root project
        peer expo@"*" from expo-dev-menu-interface@0.7.2
        node_modules/expo-dev-menu-interface
          expo-dev-menu-interface@"0.7.2" from expo-dev-menu@1.2.0
          node_modules/expo-dev-menu
            expo-dev-menu@"1.2.0" from expo-dev-launcher@1.2.0
            node_modules/expo-dev-launcher
              expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
              node_modules/expo-dev-client
                expo-dev-client@"~1.2.0" from the root project
            expo-dev-menu@"1.2.0" from expo-dev-client@1.2.0
            node_modules/expo-dev-client
              expo-dev-client@"~1.2.0" from the root project
          expo-dev-menu-interface@"0.7.2" from expo-dev-client@1.2.0
          node_modules/expo-dev-client
            expo-dev-client@"~1.2.0" from the root project
        peer expo@"*" from expo-error-recovery@3.2.0
        node_modules/expo-error-recovery
          optional expo-error-recovery@"~3.2.0" from expo@46.0.7
        peer expo@"*" from expo-file-system@14.1.0
        peer expo@"*" from expo-font@10.2.0
        node_modules/expo-font
          expo-font@"~10.2.0" from expo@46.0.7
        peer expo@"*" from expo-localization@13.1.0
        node_modules/expo-localization
          expo-localization@"~13.1.0" from the root project
        peer expo@"*" from expo-keep-awake@10.2.0
        node_modules/expo-keep-awake
          expo-keep-awake@"~10.2.0" from the root project
          expo-keep-awake@"~10.2.0" from expo@46.0.7
        peer expo@"*" from expo-navigation-bar@1.3.0
        node_modules/expo-navigation-bar
          expo-navigation-bar@"~1.3.0" from the root project
        peer expo@"*" from expo-screen-orientation@4.3.0
        node_modules/expo-screen-orientation
          expo-screen-orientation@"~4.3.0" from the root project
        peer expo@"*" from expo-store-review@5.3.0
        node_modules/expo-store-review
          expo-store-review@"~5.3.0" from the root project
        peer expo@"*" from expo-updates-interface@0.7.0
        node_modules/expo-updates-interface
          expo-updates-interface@"~0.7.0" from expo-dev-client@1.2.0
          node_modules/expo-dev-client
            expo-dev-client@"~1.2.0" from the root project
        peer expo@"*" from expo-web-browser@11.0.0
        node_modules/expo-web-browser
          expo-web-browser@"~11.0.0" from the root project
    expo-file-system@"~14.1.0" from expo@46.0.7
    node_modules/expo
      expo@"^46.0.0" from the root project
      peer expo@"*" from expo-application@4.2.2
      node_modules/expo-application
        expo-application@"~4.2.2" from expo@46.0.7
      peer expo@"*" from expo-constants@13.2.3
      node_modules/expo-constants
        expo-constants@"~13.2.2" from expo-asset@8.6.1
        expo-constants@"~13.2.3" from expo@46.0.7
        expo-constants@"~13.2.0" from expo-linking@3.2.2
        node_modules/expo-linking
          expo-linking@"~3.2.2" from the root project
      peer expo@"*" from expo-av@12.0.4
      node_modules/expo-av
        expo-av@"~12.0.4" from the root project
      peer expo@"*" from expo-build-properties@0.3.0
      node_modules/expo-build-properties
        expo-build-properties@"~0.3.0" from the root project
      peer expo@"*" from expo-dev-menu@1.2.0
      node_modules/expo-dev-menu
        expo-dev-menu@"1.2.0" from expo-dev-launcher@1.2.0
        node_modules/expo-dev-launcher
          expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
          node_modules/expo-dev-client
            expo-dev-client@"~1.2.0" from the root project
        expo-dev-menu@"1.2.0" from expo-dev-client@1.2.0
        node_modules/expo-dev-client
          expo-dev-client@"~1.2.0" from the root project
      peer expo@"*" from expo-dev-launcher@1.2.0
      node_modules/expo-dev-launcher
        expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
        node_modules/expo-dev-client
          expo-dev-client@"~1.2.0" from the root project
      peer expo@"*" from expo-dev-client@1.2.0
      node_modules/expo-dev-client
        expo-dev-client@"~1.2.0" from the root project
      peer expo@"*" from expo-dev-menu-interface@0.7.2
      node_modules/expo-dev-menu-interface
        expo-dev-menu-interface@"0.7.2" from expo-dev-menu@1.2.0
        node_modules/expo-dev-menu
          expo-dev-menu@"1.2.0" from expo-dev-launcher@1.2.0
          node_modules/expo-dev-launcher
            expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
            node_modules/expo-dev-client
              expo-dev-client@"~1.2.0" from the root project
          expo-dev-menu@"1.2.0" from expo-dev-client@1.2.0
          node_modules/expo-dev-client
            expo-dev-client@"~1.2.0" from the root project
        expo-dev-menu-interface@"0.7.2" from expo-dev-client@1.2.0
        node_modules/expo-dev-client
          expo-dev-client@"~1.2.0" from the root project
      peer expo@"*" from expo-error-recovery@3.2.0
      node_modules/expo-error-recovery
        optional expo-error-recovery@"~3.2.0" from expo@46.0.7
      peer expo@"*" from expo-file-system@14.1.0
      peer expo@"*" from expo-font@10.2.0
      node_modules/expo-font
        expo-font@"~10.2.0" from expo@46.0.7
      peer expo@"*" from expo-localization@13.1.0
      node_modules/expo-localization
        expo-localization@"~13.1.0" from the root project
      peer expo@"*" from expo-keep-awake@10.2.0
      node_modules/expo-keep-awake
        expo-keep-awake@"~10.2.0" from the root project
        expo-keep-awake@"~10.2.0" from expo@46.0.7
      peer expo@"*" from expo-navigation-bar@1.3.0
      node_modules/expo-navigation-bar
        expo-navigation-bar@"~1.3.0" from the root project
      peer expo@"*" from expo-screen-orientation@4.3.0
      node_modules/expo-screen-orientation
        expo-screen-orientation@"~4.3.0" from the root project
      peer expo@"*" from expo-store-review@5.3.0
      node_modules/expo-store-review
        expo-store-review@"~5.3.0" from the root project
      peer expo@"*" from expo-updates-interface@0.7.0
      node_modules/expo-updates-interface
        expo-updates-interface@"~0.7.0" from expo-dev-client@1.2.0
        node_modules/expo-dev-client
          expo-dev-client@"~1.2.0" from the root project
      peer expo@"*" from expo-web-browser@11.0.0
      node_modules/expo-web-browser
        expo-web-browser@"~11.0.0" from the root project
  @expo/config-plugins@"~5.0.0" from expo-navigation-bar@1.3.0
  node_modules/expo-navigation-bar
    expo-navigation-bar@"~1.3.0" from the root project
  @expo/config-plugins@"~5.0.0" from expo-screen-orientation@4.3.0
  node_modules/expo-screen-orientation
    expo-screen-orientation@"~4.3.0" from the root project
  @expo/config-plugins@"~5.0.1" from @expo/cli@0.2.9
  node_modules/@expo/cli
    @expo/cli@"0.2.9" from expo@46.0.7
    node_modules/expo
      expo@"^46.0.0" from the root project
      peer expo@"*" from expo-application@4.2.2
      node_modules/expo-application
        expo-application@"~4.2.2" from expo@46.0.7
      peer expo@"*" from expo-constants@13.2.3
      node_modules/expo-constants
        expo-constants@"~13.2.2" from expo-asset@8.6.1
        expo-constants@"~13.2.3" from expo@46.0.7
        expo-constants@"~13.2.0" from expo-linking@3.2.2
        node_modules/expo-linking
          expo-linking@"~3.2.2" from the root project
      peer expo@"*" from expo-av@12.0.4
      node_modules/expo-av
        expo-av@"~12.0.4" from the root project
      peer expo@"*" from expo-build-properties@0.3.0
      node_modules/expo-build-properties
        expo-build-properties@"~0.3.0" from the root project
      peer expo@"*" from expo-dev-menu@1.2.0
      node_modules/expo-dev-menu
        expo-dev-menu@"1.2.0" from expo-dev-launcher@1.2.0
        node_modules/expo-dev-launcher
          expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
          node_modules/expo-dev-client
            expo-dev-client@"~1.2.0" from the root project
        expo-dev-menu@"1.2.0" from expo-dev-client@1.2.0
        node_modules/expo-dev-client
          expo-dev-client@"~1.2.0" from the root project
      peer expo@"*" from expo-dev-launcher@1.2.0
      node_modules/expo-dev-launcher
        expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
        node_modules/expo-dev-client
          expo-dev-client@"~1.2.0" from the root project
      peer expo@"*" from expo-dev-client@1.2.0
      node_modules/expo-dev-client
        expo-dev-client@"~1.2.0" from the root project
      peer expo@"*" from expo-dev-menu-interface@0.7.2
      node_modules/expo-dev-menu-interface
        expo-dev-menu-interface@"0.7.2" from expo-dev-menu@1.2.0
        node_modules/expo-dev-menu
          expo-dev-menu@"1.2.0" from expo-dev-launcher@1.2.0
          node_modules/expo-dev-launcher
            expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
            node_modules/expo-dev-client
              expo-dev-client@"~1.2.0" from the root project
          expo-dev-menu@"1.2.0" from expo-dev-client@1.2.0
          node_modules/expo-dev-client
            expo-dev-client@"~1.2.0" from the root project
        expo-dev-menu-interface@"0.7.2" from expo-dev-client@1.2.0
        node_modules/expo-dev-client
          expo-dev-client@"~1.2.0" from the root project
      peer expo@"*" from expo-error-recovery@3.2.0
      node_modules/expo-error-recovery
        optional expo-error-recovery@"~3.2.0" from expo@46.0.7
      peer expo@"*" from expo-file-system@14.1.0
      peer expo@"*" from expo-font@10.2.0
      node_modules/expo-font
        expo-font@"~10.2.0" from expo@46.0.7
      peer expo@"*" from expo-localization@13.1.0
      node_modules/expo-localization
        expo-localization@"~13.1.0" from the root project
      peer expo@"*" from expo-keep-awake@10.2.0
      node_modules/expo-keep-awake
        expo-keep-awake@"~10.2.0" from the root project
        expo-keep-awake@"~10.2.0" from expo@46.0.7
      peer expo@"*" from expo-navigation-bar@1.3.0
      node_modules/expo-navigation-bar
        expo-navigation-bar@"~1.3.0" from the root project
      peer expo@"*" from expo-screen-orientation@4.3.0
      node_modules/expo-screen-orientation
        expo-screen-orientation@"~4.3.0" from the root project
      peer expo@"*" from expo-store-review@5.3.0
      node_modules/expo-store-review
        expo-store-review@"~5.3.0" from the root project
      peer expo@"*" from expo-updates-interface@0.7.0
      node_modules/expo-updates-interface
        expo-updates-interface@"~0.7.0" from expo-dev-client@1.2.0
        node_modules/expo-dev-client
          expo-dev-client@"~1.2.0" from the root project
      peer expo@"*" from expo-web-browser@11.0.0
      node_modules/expo-web-browser
        expo-web-browser@"~11.0.0" from the root project
  @expo/config-plugins@"~5.0.1" from @expo/config@7.0.1
  node_modules/@expo/config
    @expo/config@"~7.0.0" from expo-constants@13.2.3
    node_modules/expo-constants
      expo-constants@"~13.2.2" from expo-asset@8.6.1
      expo-constants@"~13.2.3" from expo@46.0.7
      expo-constants@"~13.2.0" from expo-linking@3.2.2
      node_modules/expo-linking
        expo-linking@"~3.2.2" from the root project
    @expo/config@"~7.0.1" from @expo/cli@0.2.9
    node_modules/@expo/cli
      @expo/cli@"0.2.9" from expo@46.0.7
      node_modules/expo
        expo@"^46.0.0" from the root project
        peer expo@"*" from expo-application@4.2.2
        node_modules/expo-application
          expo-application@"~4.2.2" from expo@46.0.7
        peer expo@"*" from expo-constants@13.2.3
        node_modules/expo-constants
          expo-constants@"~13.2.2" from expo-asset@8.6.1
          expo-constants@"~13.2.3" from expo@46.0.7
          expo-constants@"~13.2.0" from expo-linking@3.2.2
          node_modules/expo-linking
            expo-linking@"~3.2.2" from the root project
        peer expo@"*" from expo-av@12.0.4
        node_modules/expo-av
          expo-av@"~12.0.4" from the root project
        peer expo@"*" from expo-build-properties@0.3.0
        node_modules/expo-build-properties
          expo-build-properties@"~0.3.0" from the root project
        peer expo@"*" from expo-dev-menu@1.2.0
        node_modules/expo-dev-menu
          expo-dev-menu@"1.2.0" from expo-dev-launcher@1.2.0
          node_modules/expo-dev-launcher
            expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
            node_modules/expo-dev-client
              expo-dev-client@"~1.2.0" from the root project
          expo-dev-menu@"1.2.0" from expo-dev-client@1.2.0
          node_modules/expo-dev-client
            expo-dev-client@"~1.2.0" from the root project
        peer expo@"*" from expo-dev-launcher@1.2.0
        node_modules/expo-dev-launcher
          expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
          node_modules/expo-dev-client
            expo-dev-client@"~1.2.0" from the root project
        peer expo@"*" from expo-dev-client@1.2.0
        node_modules/expo-dev-client
          expo-dev-client@"~1.2.0" from the root project
        peer expo@"*" from expo-dev-menu-interface@0.7.2
        node_modules/expo-dev-menu-interface
          expo-dev-menu-interface@"0.7.2" from expo-dev-menu@1.2.0
          node_modules/expo-dev-menu
            expo-dev-menu@"1.2.0" from expo-dev-launcher@1.2.0
            node_modules/expo-dev-launcher
              expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
              node_modules/expo-dev-client
                expo-dev-client@"~1.2.0" from the root project
            expo-dev-menu@"1.2.0" from expo-dev-client@1.2.0
            node_modules/expo-dev-client
              expo-dev-client@"~1.2.0" from the root project
          expo-dev-menu-interface@"0.7.2" from expo-dev-client@1.2.0
          node_modules/expo-dev-client
            expo-dev-client@"~1.2.0" from the root project
        peer expo@"*" from expo-error-recovery@3.2.0
        node_modules/expo-error-recovery
          optional expo-error-recovery@"~3.2.0" from expo@46.0.7
        peer expo@"*" from expo-file-system@14.1.0
        peer expo@"*" from expo-font@10.2.0
        node_modules/expo-font
          expo-font@"~10.2.0" from expo@46.0.7
        peer expo@"*" from expo-localization@13.1.0
        node_modules/expo-localization
          expo-localization@"~13.1.0" from the root project
        peer expo@"*" from expo-keep-awake@10.2.0
        node_modules/expo-keep-awake
          expo-keep-awake@"~10.2.0" from the root project
          expo-keep-awake@"~10.2.0" from expo@46.0.7
        peer expo@"*" from expo-navigation-bar@1.3.0
        node_modules/expo-navigation-bar
          expo-navigation-bar@"~1.3.0" from the root project
        peer expo@"*" from expo-screen-orientation@4.3.0
        node_modules/expo-screen-orientation
          expo-screen-orientation@"~4.3.0" from the root project
        peer expo@"*" from expo-store-review@5.3.0
        node_modules/expo-store-review
          expo-store-review@"~5.3.0" from the root project
        peer expo@"*" from expo-updates-interface@0.7.0
        node_modules/expo-updates-interface
          expo-updates-interface@"~0.7.0" from expo-dev-client@1.2.0
          node_modules/expo-dev-client
            expo-dev-client@"~1.2.0" from the root project
        peer expo@"*" from expo-web-browser@11.0.0
        node_modules/expo-web-browser
          expo-web-browser@"~11.0.0" from the root project
    @expo/config@"7.0.1" from @expo/prebuild-config@5.0.3
    node_modules/@expo/prebuild-config
      @expo/prebuild-config@"~5.0.3" from @expo/cli@0.2.9
      node_modules/@expo/cli
        @expo/cli@"0.2.9" from expo@46.0.7
        node_modules/expo
          expo@"^46.0.0" from the root project
          peer expo@"*" from expo-application@4.2.2
          node_modules/expo-application
            expo-application@"~4.2.2" from expo@46.0.7
          peer expo@"*" from expo-constants@13.2.3
          node_modules/expo-constants
            expo-constants@"~13.2.2" from expo-asset@8.6.1
            expo-constants@"~13.2.3" from expo@46.0.7
            expo-constants@"~13.2.0" from expo-linking@3.2.2
            node_modules/expo-linking
              expo-linking@"~3.2.2" from the root project
          peer expo@"*" from expo-av@12.0.4
          node_modules/expo-av
            expo-av@"~12.0.4" from the root project
          peer expo@"*" from expo-build-properties@0.3.0
          node_modules/expo-build-properties
            expo-build-properties@"~0.3.0" from the root project
          peer expo@"*" from expo-dev-menu@1.2.0
          node_modules/expo-dev-menu
            expo-dev-menu@"1.2.0" from expo-dev-launcher@1.2.0
            node_modules/expo-dev-launcher
              expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
              node_modules/expo-dev-client
                expo-dev-client@"~1.2.0" from the root project
            expo-dev-menu@"1.2.0" from expo-dev-client@1.2.0
            node_modules/expo-dev-client
              expo-dev-client@"~1.2.0" from the root project
          peer expo@"*" from expo-dev-launcher@1.2.0
          node_modules/expo-dev-launcher
            expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
            node_modules/expo-dev-client
              expo-dev-client@"~1.2.0" from the root project
          peer expo@"*" from expo-dev-client@1.2.0
          node_modules/expo-dev-client
            expo-dev-client@"~1.2.0" from the root project
          peer expo@"*" from expo-dev-menu-interface@0.7.2
          node_modules/expo-dev-menu-interface
            expo-dev-menu-interface@"0.7.2" from expo-dev-menu@1.2.0
            node_modules/expo-dev-menu
              expo-dev-menu@"1.2.0" from expo-dev-launcher@1.2.0
              node_modules/expo-dev-launcher
                expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
                node_modules/expo-dev-client
                  expo-dev-client@"~1.2.0" from the root project
              expo-dev-menu@"1.2.0" from expo-dev-client@1.2.0
              node_modules/expo-dev-client
                expo-dev-client@"~1.2.0" from the root project
            expo-dev-menu-interface@"0.7.2" from expo-dev-client@1.2.0
            node_modules/expo-dev-client
              expo-dev-client@"~1.2.0" from the root project
          peer expo@"*" from expo-error-recovery@3.2.0
          node_modules/expo-error-recovery
            optional expo-error-recovery@"~3.2.0" from expo@46.0.7
          peer expo@"*" from expo-file-system@14.1.0
          peer expo@"*" from expo-font@10.2.0
          node_modules/expo-font
            expo-font@"~10.2.0" from expo@46.0.7
          peer expo@"*" from expo-localization@13.1.0
          node_modules/expo-localization
            expo-localization@"~13.1.0" from the root project
          peer expo@"*" from expo-keep-awake@10.2.0
          node_modules/expo-keep-awake
            expo-keep-awake@"~10.2.0" from the root project
            expo-keep-awake@"~10.2.0" from expo@46.0.7
          peer expo@"*" from expo-navigation-bar@1.3.0
          node_modules/expo-navigation-bar
            expo-navigation-bar@"~1.3.0" from the root project
          peer expo@"*" from expo-screen-orientation@4.3.0
          node_modules/expo-screen-orientation
            expo-screen-orientation@"~4.3.0" from the root project
          peer expo@"*" from expo-store-review@5.3.0
          node_modules/expo-store-review
            expo-store-review@"~5.3.0" from the root project
          peer expo@"*" from expo-updates-interface@0.7.0
          node_modules/expo-updates-interface
            expo-updates-interface@"~0.7.0" from expo-dev-client@1.2.0
            node_modules/expo-dev-client
              expo-dev-client@"~1.2.0" from the root project
          peer expo@"*" from expo-web-browser@11.0.0
          node_modules/expo-web-browser
            expo-web-browser@"~11.0.0" from the root project
    @expo/config@"7.0.1" from @expo/metro-config@0.3.22
    node_modules/@expo/metro-config
      @expo/metro-config@"~0.3.18" from @expo/cli@0.2.9
      node_modules/@expo/cli
        @expo/cli@"0.2.9" from expo@46.0.7
        node_modules/expo
          expo@"^46.0.0" from the root project
          peer expo@"*" from expo-application@4.2.2
          node_modules/expo-application
            expo-application@"~4.2.2" from expo@46.0.7
          peer expo@"*" from expo-constants@13.2.3
          node_modules/expo-constants
            expo-constants@"~13.2.2" from expo-asset@8.6.1
            expo-constants@"~13.2.3" from expo@46.0.7
            expo-constants@"~13.2.0" from expo-linking@3.2.2
            node_modules/expo-linking
              expo-linking@"~3.2.2" from the root project
          peer expo@"*" from expo-av@12.0.4
          node_modules/expo-av
            expo-av@"~12.0.4" from the root project
          peer expo@"*" from expo-build-properties@0.3.0
          node_modules/expo-build-properties
            expo-build-properties@"~0.3.0" from the root project
          peer expo@"*" from expo-dev-menu@1.2.0
          node_modules/expo-dev-menu
            expo-dev-menu@"1.2.0" from expo-dev-launcher@1.2.0
            node_modules/expo-dev-launcher
              expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
              node_modules/expo-dev-client
                expo-dev-client@"~1.2.0" from the root project
            expo-dev-menu@"1.2.0" from expo-dev-client@1.2.0
            node_modules/expo-dev-client
              expo-dev-client@"~1.2.0" from the root project
          peer expo@"*" from expo-dev-launcher@1.2.0
          node_modules/expo-dev-launcher
            expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
            node_modules/expo-dev-client
              expo-dev-client@"~1.2.0" from the root project
          peer expo@"*" from expo-dev-client@1.2.0
          node_modules/expo-dev-client
            expo-dev-client@"~1.2.0" from the root project
          peer expo@"*" from expo-dev-menu-interface@0.7.2
          node_modules/expo-dev-menu-interface
            expo-dev-menu-interface@"0.7.2" from expo-dev-menu@1.2.0
            node_modules/expo-dev-menu
              expo-dev-menu@"1.2.0" from expo-dev-launcher@1.2.0
              node_modules/expo-dev-launcher
                expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
                node_modules/expo-dev-client
                  expo-dev-client@"~1.2.0" from the root project
              expo-dev-menu@"1.2.0" from expo-dev-client@1.2.0
              node_modules/expo-dev-client
                expo-dev-client@"~1.2.0" from the root project
            expo-dev-menu-interface@"0.7.2" from expo-dev-client@1.2.0
            node_modules/expo-dev-client
              expo-dev-client@"~1.2.0" from the root project
          peer expo@"*" from expo-error-recovery@3.2.0
          node_modules/expo-error-recovery
            optional expo-error-recovery@"~3.2.0" from expo@46.0.7
          peer expo@"*" from expo-file-system@14.1.0
          peer expo@"*" from expo-font@10.2.0
          node_modules/expo-font
            expo-font@"~10.2.0" from expo@46.0.7
          peer expo@"*" from expo-localization@13.1.0
          node_modules/expo-localization
            expo-localization@"~13.1.0" from the root project
          peer expo@"*" from expo-keep-awake@10.2.0
          node_modules/expo-keep-awake
            expo-keep-awake@"~10.2.0" from the root project
            expo-keep-awake@"~10.2.0" from expo@46.0.7
          peer expo@"*" from expo-navigation-bar@1.3.0
          node_modules/expo-navigation-bar
            expo-navigation-bar@"~1.3.0" from the root project
          peer expo@"*" from expo-screen-orientation@4.3.0
          node_modules/expo-screen-orientation
            expo-screen-orientation@"~4.3.0" from the root project
          peer expo@"*" from expo-store-review@5.3.0
          node_modules/expo-store-review
            expo-store-review@"~5.3.0" from the root project
          peer expo@"*" from expo-updates-interface@0.7.0
          node_modules/expo-updates-interface
            expo-updates-interface@"~0.7.0" from expo-dev-client@1.2.0
            node_modules/expo-dev-client
              expo-dev-client@"~1.2.0" from the root project
          peer expo@"*" from expo-web-browser@11.0.0
          node_modules/expo-web-browser
            expo-web-browser@"~11.0.0" from the root project
  @expo/config-plugins@"~5.0.1" from @expo/prebuild-config@5.0.3
  node_modules/@expo/prebuild-config
    @expo/prebuild-config@"~5.0.3" from @expo/cli@0.2.9
    node_modules/@expo/cli
      @expo/cli@"0.2.9" from expo@46.0.7
      node_modules/expo
        expo@"^46.0.0" from the root project
        peer expo@"*" from expo-application@4.2.2
        node_modules/expo-application
          expo-application@"~4.2.2" from expo@46.0.7
        peer expo@"*" from expo-constants@13.2.3
        node_modules/expo-constants
          expo-constants@"~13.2.2" from expo-asset@8.6.1
          expo-constants@"~13.2.3" from expo@46.0.7
          expo-constants@"~13.2.0" from expo-linking@3.2.2
          node_modules/expo-linking
            expo-linking@"~3.2.2" from the root project
        peer expo@"*" from expo-av@12.0.4
        node_modules/expo-av
          expo-av@"~12.0.4" from the root project
        peer expo@"*" from expo-build-properties@0.3.0
        node_modules/expo-build-properties
          expo-build-properties@"~0.3.0" from the root project
        peer expo@"*" from expo-dev-menu@1.2.0
        node_modules/expo-dev-menu
          expo-dev-menu@"1.2.0" from expo-dev-launcher@1.2.0
          node_modules/expo-dev-launcher
            expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
            node_modules/expo-dev-client
              expo-dev-client@"~1.2.0" from the root project
          expo-dev-menu@"1.2.0" from expo-dev-client@1.2.0
          node_modules/expo-dev-client
            expo-dev-client@"~1.2.0" from the root project
        peer expo@"*" from expo-dev-launcher@1.2.0
        node_modules/expo-dev-launcher
          expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
          node_modules/expo-dev-client
            expo-dev-client@"~1.2.0" from the root project
        peer expo@"*" from expo-dev-client@1.2.0
        node_modules/expo-dev-client
          expo-dev-client@"~1.2.0" from the root project
        peer expo@"*" from expo-dev-menu-interface@0.7.2
        node_modules/expo-dev-menu-interface
          expo-dev-menu-interface@"0.7.2" from expo-dev-menu@1.2.0
          node_modules/expo-dev-menu
            expo-dev-menu@"1.2.0" from expo-dev-launcher@1.2.0
            node_modules/expo-dev-launcher
              expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
              node_modules/expo-dev-client
                expo-dev-client@"~1.2.0" from the root project
            expo-dev-menu@"1.2.0" from expo-dev-client@1.2.0
            node_modules/expo-dev-client
              expo-dev-client@"~1.2.0" from the root project
          expo-dev-menu-interface@"0.7.2" from expo-dev-client@1.2.0
          node_modules/expo-dev-client
            expo-dev-client@"~1.2.0" from the root project

… still more, pls see the comment

This error is too long for 1 message, so below is the remaining:

peer expo@"*" from expo-error-recovery@3.2.0
       node_modules/expo-error-recovery
         optional expo-error-recovery@"~3.2.0" from expo@46.0.7
       peer expo@"*" from expo-file-system@14.1.0
       peer expo@"*" from expo-font@10.2.0
       node_modules/expo-font
         expo-font@"~10.2.0" from expo@46.0.7
       peer expo@"*" from expo-localization@13.1.0
       node_modules/expo-localization
         expo-localization@"~13.1.0" from the root project
       peer expo@"*" from expo-keep-awake@10.2.0
       node_modules/expo-keep-awake
         expo-keep-awake@"~10.2.0" from the root project
         expo-keep-awake@"~10.2.0" from expo@46.0.7
       peer expo@"*" from expo-navigation-bar@1.3.0
       node_modules/expo-navigation-bar
         expo-navigation-bar@"~1.3.0" from the root project
       peer expo@"*" from expo-screen-orientation@4.3.0
       node_modules/expo-screen-orientation
         expo-screen-orientation@"~4.3.0" from the root project
       peer expo@"*" from expo-store-review@5.3.0
       node_modules/expo-store-review
         expo-store-review@"~5.3.0" from the root project
       peer expo@"*" from expo-updates-interface@0.7.0
       node_modules/expo-updates-interface
         expo-updates-interface@"~0.7.0" from expo-dev-client@1.2.0
         node_modules/expo-dev-client
           expo-dev-client@"~1.2.0" from the root project
       peer expo@"*" from expo-web-browser@11.0.0
       node_modules/expo-web-browser
         expo-web-browser@"~11.0.0" from the root project

@expo/config-plugins@4.1.5
node_modules/@expo/dev-server/node_modules/@expo/config-plugins
 @expo/config-plugins@"4.1.5" from @expo/config@6.0.24
 node_modules/@expo/dev-server/node_modules/@expo/config
   @expo/config@"6.0.24" from @expo/metro-config@0.3.18
   node_modules/@expo/dev-server/node_modules/@expo/metro-config
     @expo/metro-config@"0.3.18" from @expo/dev-server@0.1.113
     node_modules/@expo/dev-server
       @expo/dev-server@"~0.1.110" from @expo/cli@0.2.9
       node_modules/@expo/cli
         @expo/cli@"0.2.9" from expo@46.0.7
         node_modules/expo
           expo@"^46.0.0" from the root project
           peer expo@"*" from expo-application@4.2.2
           node_modules/expo-application
             expo-application@"~4.2.2" from expo@46.0.7
           peer expo@"*" from expo-constants@13.2.3
           node_modules/expo-constants
             expo-constants@"~13.2.2" from expo-asset@8.6.1
             expo-constants@"~13.2.3" from expo@46.0.7
             expo-constants@"~13.2.0" from expo-linking@3.2.2
             node_modules/expo-linking
               expo-linking@"~3.2.2" from the root project
           peer expo@"*" from expo-av@12.0.4
           node_modules/expo-av
             expo-av@"~12.0.4" from the root project
           peer expo@"*" from expo-build-properties@0.3.0
           node_modules/expo-build-properties
             expo-build-properties@"~0.3.0" from the root project
           peer expo@"*" from expo-dev-menu@1.2.0
           node_modules/expo-dev-menu
             expo-dev-menu@"1.2.0" from expo-dev-launcher@1.2.0
             node_modules/expo-dev-launcher
               expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
               node_modules/expo-dev-client
                 expo-dev-client@"~1.2.0" from the root project
             expo-dev-menu@"1.2.0" from expo-dev-client@1.2.0
             node_modules/expo-dev-client
               expo-dev-client@"~1.2.0" from the root project
           peer expo@"*" from expo-dev-launcher@1.2.0
           node_modules/expo-dev-launcher
             expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
             node_modules/expo-dev-client
               expo-dev-client@"~1.2.0" from the root project
           peer expo@"*" from expo-dev-client@1.2.0
           node_modules/expo-dev-client
             expo-dev-client@"~1.2.0" from the root project
           peer expo@"*" from expo-dev-menu-interface@0.7.2
           node_modules/expo-dev-menu-interface
             expo-dev-menu-interface@"0.7.2" from expo-dev-menu@1.2.0
             node_modules/expo-dev-menu
               expo-dev-menu@"1.2.0" from expo-dev-launcher@1.2.0
               node_modules/expo-dev-launcher
                 expo-dev-launcher@"1.2.0" from expo-dev-client@1.2.0
                 node_modules/expo-dev-client
                   expo-dev-client@"~1.2.0" from the root project
               expo-dev-menu@"1.2.0" from expo-dev-client@1.2.0
               node_modules/expo-dev-client
                 expo-dev-client@"~1.2.0" from the root project
             expo-dev-menu-interface@"0.7.2" from expo-dev-client@1.2.0
             node_modules/expo-dev-client
               expo-dev-client@"~1.2.0" from the root project
           peer expo@"*" from expo-error-recovery@3.2.0
           node_modules/expo-error-recovery
             optional expo-error-recovery@"~3.2.0" from expo@46.0.7
           peer expo@"*" from expo-file-system@14.1.0
           peer expo@"*" from expo-font@10.2.0
           node_modules/expo-font
             expo-font@"~10.2.0" from expo@46.0.7
           peer expo@"*" from expo-localization@13.1.0
           node_modules/expo-localization
             expo-localization@"~13.1.0" from the root project
           peer expo@"*" from expo-keep-awake@10.2.0
           node_modules/expo-keep-awake
             expo-keep-awake@"~10.2.0" from the root project
             expo-keep-awake@"~10.2.0" from expo@46.0.7
           peer expo@"*" from expo-navigation-bar@1.3.0
           node_modules/expo-navigation-bar
             expo-navigation-bar@"~1.3.0" from the root project
           peer expo@"*" from expo-screen-orientation@4.3.0
           node_modules/expo-screen-orientation
             expo-screen-orientation@"~4.3.0" from the root project
           peer expo@"*" from expo-store-review@5.3.0
           node_modules/expo-store-review
             expo-store-review@"~5.3.0" from the root project
           peer expo@"*" from expo-updates-interface@0.7.0
           node_modules/expo-updates-interface
             expo-updates-interface@"~0.7.0" from expo-dev-client@1.2.0
             node_modules/expo-dev-client
               expo-dev-client@"~1.2.0" from the root project
           peer expo@"*" from expo-web-browser@11.0.0
           node_modules/expo-web-browser
             expo-web-browser@"~11.0.0" from the root project

Any ideas what’s going on? What should I do? Many many thanks!! :pray: :pray: :pray:

Hi @rachellauyui

You’ll get more manageable output with npm why @expo/config-plugins@4.1.5 :slight_smile:

But basically it’s coming from @expo/config-plugins@"4.1.5"@expo/config@"6.0.24"@expo/metro-config@"0.3.18"@expo/dev-server@"~0.1.110"@expo/cli@"0.2.9"expo@"^46.0.0" from the root project

So I believe this is just a case of some dependencies of expo being a bit out of date.

You can try running npx expo install --fix and expo doctor --fix-dependencies, but I think you might have to just remove your package-lock.json / yarn.lock and node_modules and re-install your dependencies.

If that doesn’t fix it, then you can try running npx expo install <depname> for each of your dependencies (skipping any you know you don’t want to upgrade) and then maybe try removing the lock file and node_modules and re-installing your dependencies again.

Ideally expo doctor --fix-dependencies or npx expo install --fix should fix things for you, but in practice I have found they don’t always fix stuff like this.

1 Like

Hi @wodin Michael!!

Thank you very much for the quick reply… As you predicted, the fixing does not fix the App. After I delete node.module and yarn.lock, cannot install any dependencies at all… So, I init a new file and start from scratch… Just send to build, at least Expo Doc is happy this time!

You really help me and many others a lot! You are the BEST!!!

1 Like

After deleting those you should just be able to run yarn (with no arguments) and it should re-install all of your dependencies.

I’m glad you have it working now.

1 Like

Gee… How come I never know it? I just used my old file and run just yarn… Wow, it is so much faster!

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.