[Account] Request failed with status code 401

Hello everyone,

I think my account has a problem, exp build:android and exp build:ios
returns this error:

21:45:34 [exp] Request failed with status code 401
21:45:34 [exp] Error: Request failed with status code 401
    at createError (/usr/local/lib/node_modules/exp/node_modules/axios/lib/core/createError.js:16:15)
    at settle (/usr/local/lib/node_modules/exp/node_modules/axios/lib/core/settle.js:18:12)
    at IncomingMessage.handleStreamEnd (/usr/local/lib/node_modules/exp/node_modules/axios/lib/adapters/http.js:191:11)
    at IncomingMessage.emit (events.js:187:15)
    at endReadableNT (_stream_readable.js:1086:12)
    at process._tickCallback (internal/process/next_tick.js:63:19)

I tried everything, searched a lot, tried asking on Slack, but no-one seems to be able to help.
I’ve tried creating another account in despair, and it works with that secondary account !
But, what is the problem, and how can I fix my main account ?
Thanks a lot for any answer

Having the same issue. Can’t use build commands as I get 401 error. Creating a secondary mock account didn’t work for me either.

Does the problem keep happening when you run exp logout and exp login back into the effected account?

Also, just in case, what are your account names?

Please run npm i -g exp too to make sure you’re running the most recent version of exp

Same issue here.

@rudiko @exlor @pizzamarinara we just pushed a fix for this issue. Could you try:

  1. running exp build:android
  2. if it fails, run exp logout && exp login then exp build:android
  3. if it still fails, can you send us the contents of ~/.expo/state.json and the output for EXPO_DEBUG=true exp build:android or whichever command is failing to support@expo.io?

thanks, and sorry for the inconvenience

1 Like

Works now! Thanks.

Can confirm it works with my main account as well. Thank you!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.