AccessbilityInfo error while using Expo-firebase-auth

I’ve been getting an AccessibilityInfo error that is described as:
“Unable to resolve module AccessibilityInfo from C:\Users.…\node_modules\expo-firebase-auth\node_modules\react-native\Libraries\react-native\react-native-implementation.js: AccessibilityInf node_modules\expo-firebase-auth\node_modules”
Not sure if I need to downgrade my react or expo versions but I’m using

“expo”: “^46.0.0”,
“expo-av”: “~12.0.4”,
“expo-dev-client”: “~1.3.1”,
“expo-firebase-auth”: “^2.0.0”,
“expo-status-bar”: “~1.4.2”,
“firebase”: “^9.15.0”,
“react”: “18.0.0”,
“react-native”: “0.69.6”,
I think the issue here is finding the compatible versions of firebase (expo-firebase-auth specifically) and expo. Mind you, I updated my dependencies before adding firebase to my app. Also, good to note that I’ve been developing on iOS.
If anyone knows, which versions of expo are compatible with firebase auth?