"32.0.0 is not a valid SDK version "

When trying to start a project in React Native using Expo, I am getting am error message saying “32.0.0 is not a valid SDK version”. I have tried updating Node, updating Expo, etc. but nothing has worked thus far. I have also been getting a message that Expo is no longer compatible with my device (Android ).

Hey @cweibel73,

Could you run expo diagnostics in your CLI and paste the output here?


Expo CLI 2.11.6 environment info:
OS: Windows 10
Node: 10.15.2 - C:\node.EXE
Yarn: 1.3.2 - C:\Users\cweibel\AppData\Roaming\npm\yarn.CMD
npm: 6.8.0 - C:\npm.CMD
Android Studio: Version AI-173.4720617

1 Like

Great, thank you! And are you trying to initialize a project with the expo-cli, or you already have one and you’re trying to start a local server for it (as with expo start)?

I was trying to set up sort of a practice program (I’m very new to React Native) from the command line. I created the directory, but ran into the error message when I attempted to scan the QR code.

I just made another attempt, and this time received a message in the DevTools in the browser that my Expo app was out of date, and that if I uninstalled the app and tried again, a newer version would open on my device. I tried that, but received this error message:

Couldn’t start project on Android: Error running adb: Error running app. Error: Activity not started, unable to resolve Intent { act=android.intent.action.VIEW dat=exp:// flg=0x10000000 }

Looks like I can’t use Expo on my phone because it is Android 4.4.2 and 5 is the minimum.

I also get the same error.

and this is the result of expo diagnostics :

Expo CLI 3.4.1 environment info:
OS: Windows 10
npm: 6.10.2 - C:\Program Files\nodejs\npm.CMD
Android Studio: Version AI-191.8026.42.35.5791312

and I use expo start like I normally do with 32.0.0

problem solved by re-installing expo client

Same error for me.

I did :

npm -g uninstall expo-cli
npm install --global expo-cli
expo diagnostics

  Expo CLI 3.13.6 environment info:
      OS: Windows 10 10.0.18363
      Node: 10.15.0 - C:\Program Files\nodejs\node.EXE
      npm: 6.4.1 - C:\Program Files\nodejs\npm.CMD
      Android Studio: Version AI-191.8026.42.35.5900203
      expo: ~36.0.0 => 36.0.2
      react: ~16.9.0 => 16.9.0
      react-native: https://github.com/expo/react-native/archive/sdk-36.0.0.tar.gz => 0.61.4

Client version
Supported SDK’s: 33, 34 ,35 36

I also init new project :

expo init my-new-project
cd my-new-project
expo start

Here is app.json generated

  "expo": {
    "name": "Blank Template",
    "slug": "my-project",
    "privacy": "public",
    "sdkVersion": "36.0.0",
    "platforms": [
    "version": "1.0.0",
    "orientation": "portrait",
    "icon": "./assets/icon.png",
    "splash": {
      "image": "./assets/splash.png",
      "resizeMode": "contain",
      "backgroundColor": "#ffffff"
    "updates": {
      "fallbackToCacheTimeout": 0
    "assetBundlePatterns": [
    "ios": {
      "supportsTablet": true

I remove and install android studio with SDK

Still this error :
Something went wrong
32.0.0 is not a valid SDK version. Options are 35.0.0,36.0.0, 34.0.0, 33.0.0 UNVERSIONED

Any ideas ? I don’t see what else I can do.

thank you !

I restarted my computer.

It still failed… but I don’t know why “tunnel” mode didn’t show any error message.

I changed connexion mode to tunnel and it works !

I don’t understand what’s going on…

I just typed expo update 35 in my project directory, and it started working again.https://docs.expo.io/versions/latest/workflow/upgrading-expo-sdk-walkthrough/